Support of Ruby 2.4 has ended

22/06/2020
Artículo original

Anunciamos que ha terminado todo el soporte para la serie Ruby 2.4.

Desde el final de Marzo del año pasado, el soporte para la serie Ruby 2.4 estaba en fase de mantenimiento de seguridad. Ahora, después de un año, esta fase ha terminado. Por tanto, en Marzo 31 de 2020 todo soporte de la serie Ruby 2.4 ha terminado. Las correcciones de fallas y de seguridad de las versiones de Ruby más recientes ya no se retro-portarán a 2.4, ni se publicarán nuevas versiones de la serie 2.4. Pulicamos Ruby 2.4.10 el 31 de Marzo de 2020, pero para dar a los usuarios un poco de tiempo para pasar a las versiones más recientes. Recomendamos con enfásis que actualice a las versiones más recientes de Ruby tan pronto como sea posible.

Sobre las versiones de Ruby soportadas en la actualidad

Serie Ruby 2.7

En fase de mantenimento normal. Retro-portaremos correcciones a fallas y publicaremos nuevas versiones con las correcciones cuando sea necesario. Y, si se encuentra un problema de seguridad crítico, publicaremos una corrección urgente para esta.

Serie Ruby 2.6

En fase de mantenimiento normal. Retro-portaremos correcciones a fallas y publicaremos nuevas versiones con las correcciones cuando sea necesario. Y, si se encuentra un problema de seguridad crítico, publicaremos una corrección urgente para esta.

Serie Ruby 2.5

En fase de mantenimiento de seguridad. No retro-portaremos correcciones a fallas a la serie 2.5, excepto fallas de seguridad. Si se encuentra un problema de seguridad crítico, publicaremos una corrección urgente para esta. Planeamos terminar el soporte para la serie Ruby 2.5 al final de Marzo de 2021.

Publicado por usa el 2020-04-05
Traducción de vtamara